Nous sommes le Lun 14 Oct, 2019 12:50
Supprimer les cookies

Pb de mise à jour de paquets

Le choix d'Ubuntu pour mes premiers pas Linux

Mer 19 Jan, 2005 13:41

Bonjour,

Je cherche à mettre à jour des paquets via synaptics ou dkpg directement et je me trouve confronté à un problème.
Voici le message :

"Preconfiguring packages ...
(Lecture de la base de données... dpkg : erreur de traitement de /var/cache/apt/archives/libmagick6_5%3a6.0.2.5-1ubuntu1.3_i386.deb (--unpack) :
files list file for package `libgimp2.0' is missing final newline
Des erreurs ont été rencontrées pendant l'exécution :
/var/cache/apt/archives/libmagick6_5%3a6.0.2.5-1ubuntu1.3_i386.deb
L'exécution a été arrêtée car il y avait trop d'erreurs.
E: Sub-process /usr/bin/dpkg returned an error code (1)"



Quelqu'un aurait-il une idée ?
Je ne suis pas très doué...

Merci
buenaventura_d

Messages : 4

Mer 19 Jan, 2005 13:50

bizarre... ça donne l'impression que le packetage n'est pas correct... (mais bon, sous réserves, je ne m'y connais pas beaucoup). Tu l'as récupéré où ? Sur le site de Debian ?
Nico

Messages : 841
Géo : Paris

Mer 19 Jan, 2005 13:59

Nico a écrit:bizarre... ça donne l'impression que le packetage n'est pas correct... (mais bon, sous réserves, je ne m'y connais pas beaucoup). Tu l'as récupéré où ? Sur le site de Debian ?


Non, j'ai récupéré tous les paquets sur les sites ubuntu...
Et lorsque je veux le désinstaller pour le réinstaller, il doit désinstaller ubuntu -desktop et là ça coince... Je ne sais pas trop comment faire...
buenaventura_d

Messages : 4

Mer 19 Jan, 2005 14:18

Ca fait ça pour tous les paquets ou juste celui-là ?
Essaie d'installer libgimp2.0 manuellement :
http://packages.debian.org/unstable/libs/libgimp2.0
puis installe le avec dpkg -i nom-du-packetage.deb.
Nico

Messages : 841
Géo : Paris

Mer 19 Jan, 2005 14:34

Nico a écrit:Ca fait ça pour tous les paquets ou juste celui-là ?
Essaie d'installer libgimp2.0 manuellement :
http://packages.debian.org/unstable/libs/libgimp2.0
puis installe le avec dpkg -i nom-du-packetage.deb.


Ca fait ça pour tous les paquets, et me donne toujours cette erreur précise.
Je vais essayer ta manip' ce soir.
Encore merci
buenaventura_d

Messages : 4

Mer 19 Jan, 2005 21:29

Je viens de tenter la manip' mais ça ne fonctionne toujours pas...
Visiblement tout le processus d'installation, de mise à jour, etc de paquets semble bloqué.
buenaventura_d

Messages : 4

Mer 19 Jan, 2005 23:53

t'as essayé :apt-get update et apt-get upgrade ?
trapik

Messages : 326

Ven 04 Fév, 2005 00:19

A mon avis il y a eu un problème avec différents paquets. Ca peut arriver.
Fais un apt-get clean avant de refaire un apt-get update et apt-get install nom_du_logiciel. Le "clean", c'est pour virer tout ce qu'il y a dans /var/cache/apt.

Bien à vous

Sdj
Sdj

Messages : 651
Géo : Tours

Ven 04 Fév, 2005 00:36

Oui, Sdj a raison et puis tentes aussi une mise à jour de la librairie libgimp2.0 seule (comme te l'avait indiqué Nico) tout en passant par "apt-get install libgimp2.0" ou via Synaptic.

As-tu modifié "/etc/apt/sources.list" (ou la liste des dépots depuis Synaptic) ?
As-tu Ajouté/Modifié/Supprimé/Activé/Désactivé des sources dans ce fichier ?
Si cette librairie pose des problèmes depuis les sources Ubuntu, essaies avec les sources Debian :
- source "ftp://ftp.debian.org/debian/"
- distribution "main"
- catégorie "stable", "testing" ou "unstable"

Quelle est la version de cette lib (elle est en conflit avec les libgimp1.3 alors regardes si tu n'as pas les 2) ?
GnapZ

Messages : 244

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit