Nous sommes le Ven 23 Août, 2019 12:38
Supprimer les cookies

mise à jour d'un programme

Le choix d'Ubuntu pour mes premiers pas Linux

Jeu 01 Juil, 2010 20:26

Bonjour,

j'ai une petite question de "newbie":

J'ai installé récemment le VLC de la distro Ubuntu Lucid soit la 1.0.6. La 1.1 vient de sortir, cool. Sur le site il est expliqué qu'en faisant un "apt-get update" suivi d'un "apt-get install vlc" cela met à jour le programme. Cela m'étonnait sachant que Ubuntu met à jour uniquement tous les 6 mois, mais j'ai essayé, et j'ai bien sûr un message qui m'indique que j'ai bien la dernière version installée, à savoir la 1.0.6.

Où donc est le bins alors ? Et bien je vois qu'il existe un deb pour la 1.1 à cette adresse:
ftp://ftp.ubuntu.com/ubuntu/pool/univer ... 1_i386.deb
Et là je ne comprend plus, puisque d'une part l'update est tous les six mois en théorie, de plus j'ai ce message indiquant que j'ai déjà la dernière version et pour finir dans le software center, je lis pour ce logiciel cette indication ni-oui-ni-non: "Canonical does not provide updates for vlc media player (ce qui semble contredire un gars sur un forum qui disait que les fix sont installés même si le numéro de version ne change pas), some updates may be provided by the Ubuntu community".

En fait je site vlc mais cela pourrait être un autre programme comme gimp, récemment passé en 2.6.9.

Alors, on peut mettre à jour ou pas, c'est quoi ce bin deb ? faut-il activer le fameux dépôt backport pour y accéder ? ou la vérité est encore ailleurs ?
popart

Avatar de l’utilisateur
Messages : 242

Jeu 01 Juil, 2010 20:33

Le .deb est un paquetage logiciel qui permet d'installer un logiciel sous les distributions Debian-like. Pour l'installer, il faut télécharger le .deb puis l'installer en double-cliquant dessus ou en tapant la commande suivante : dpkg -i nom_de_deb.deb

Cela te permettra d'avoir la dernière version du logiciel.
cheval_boiteux

Avatar de l’utilisateur
Messages : 1531
Géo : Dole (39) - Strasbourg (67)

Jeu 01 Juil, 2010 21:35

cheval_boiteux a écrit:Le .deb est un paquetage logiciel qui permet d'installer un logiciel sous les distributions Debian-like. Pour l'installer, il faut télécharger le .deb puis l'installer en double-cliquant dessus ou en tapant la commande suivante : dpkg -i nom_de_deb.deb

Cela te permettra d'avoir la dernière version du logiciel.


salut, je te remercie pour ton intervention mais ct pas vraiment la question, je sais ce qu'est un deb et quoi en faire (c'est une des possibilités pour installer un soft sous linux -- et pas la meilleure)... ma question était plutôt orientée --par exemple-- sur la présence et la nature de ce deb (dont j'ignore le degré de compatibilité avec lucid) sur le site officiel d'ubuntu sachant la politique de canonical en matière d'update, et qu'il fallait p-être evisagé l'activation des backport ou pire des proposed...

Merci quand même...
popart

Avatar de l’utilisateur
Messages : 242

Jeu 01 Juil, 2010 22:17

Bonjour,

Entre deux versions de la distribution Ubuntu, tous les six mois, il y a quand même les mises à jour automatiques, donc patience, VLC sera mis à jour bientôt par ce biais, si tu l'as installé par le système d'ajout de programmes d'Ubuntu.
jpto

Messages : 60

Ven 02 Juil, 2010 13:52

Tu peux utiliser un dépôt "parallèle".

Voir la doc Ubuntu.
Sous [color=#008000]LinuxMint[/color] (Sarah - Cinnamon 64 bits) (de moins en moins sous Windows XP ou Seven)
serged

Avatar de l’utilisateur
Messages : 1300
Géo : Montrouge (92)

Ven 02 Juil, 2010 14:19

Bonjour,

Dans le monde des dérivés de la distribution debian, la principale source d'installation de logiciel reste le passage par les dépôts (et l'utilisation d'apt-get ou d'aptitude/synaptic). Mais il n'est pas du tout interdit d'installer à la main un paquet (via dpkg, de toute façon utilisée par apt-get et aptitude), même si cela est fortement déconseillé (car pouvant "casser" des dépendance).

Par défaut, les distributions proposent un certain nombre de dépôt suite à leur installation. Généralement ces dépôts sont liés à des versions spécifiques de la distributions (peu de "rolling release" dans le monde debian). Ubuntu va plus loin en proposant une granularité plus importante dans ses dépôts :
  • universe, multiverse... correspondant plus ou moins aux free, non-free de debian si je ne m'abuse
  • backport qui correspond à des paquet introduit dans la version n+1 de la distribution, mais adapté à la version n (ce qui permet par exemple d'obtenir des mises à jours plus "fraiches" en fonction de l'avancé des travaux de la version n+1 de la distribution). Les backports ne sont pas "dangereux" pour une utilisation quotidienne, mais fortement déconseillé sur un serveur (les logiciels peuvent être jeunes, mais en aucun cas instable normalement). Le terme de backport peut se rapprocher de l'habitude de mixer, chez debian, des dépots dit "stable" des dépôts de la future version (mais c'est plus périlleux)...
  • proposed, qui, comme le nom l'indique, concerne les paquets proposés. Donc oui, là ça peut faire mal.

Mais bien sûr, rien ni personne n'empêche l'utilisateur d'ajouter d'autres dépôts à son système, afin d'enrichir la bibliothèque logicielle ou d'obtenir des versions plus à jours.

Mais bien sûr, dès que l'on sort des chemins battus, il faut s'attendre à parfois mettre les mains dans le camboui ou faire preuve d'un peu plus de rigueur.
Il faut également avoir à l'esprit que parfois les cycles d'acceptation d'un paquet dans les dépôts "officiels" sont long et tortueux (surtout pour un logiciel peu utilisé). Ainsi pendant un temps, pour avoir la dernière version de flightgear en paquet sous debian il fallait utilisé un dépôt tiers absolument pas sécurisé !
Donc il faut choisir : soit se baser exclusivement sur les dépôts de base de sa distribution (dans ce cas je te confirme que la version de vlc pour ubuntu est la 1.0.6, et il me semble également que les dépôts "backport" n'ont pas encore été ouvert pour cette version car maverick n'est pas assez avancé), soit on s'autorise quelques écarts et dans ce cas, à toi de juger la fiabilité de la provenance de ton paquet et de sa bonne intégration dans ton système. Là comme ça je te dirais :

  • Tu a trouvé un paquet sur un serveur ftp appartenant à canonical, ce qui pour moi est une source sûre
  • Il s'agit de VLC, projet mature, et avec un peu de chance le paquet provient d'un développeur de VLC, donc peut de chance que le paquet lui même soit mal fichu
  • Mais vlc trimbale pas mal de dépendance dans l'ecosystème debian (libvlccore entre autre) et j'ai peur qu'installer exclusivement ce paquet "à la main" sans prendre également la nouvelle version de toutes les dépendances ne soit un peu risqué (enfin ça risque juste de casser vlc, rien de grave mais bon ^^)
Du coup, moi je dirais simplement d'attendre un peu, ou de commencer par désinstaller complètement la version vlc de ton système avant d'installer cette version là.

Et au pire, ce qui est magique avec les dépôt, c'est que si tu installe un version buggé d'un logiciel, tu sais que tu pourras toujours réinstaller la version de base présente dans les dépôts :)
Tant que tu ne touche pas aux grosse librairies systèmes ou au noyau, et tant que la source est fiable (évite les paquets provenant du site k3v1n_underground_repository ;)) il y a peu de chance de casser complètement ton système.
milouse

Avatar de l’utilisateur
Messages : 637
Géo : Nantes

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit