Nous sommes le Lun 19 Août, 2019 15:24
Supprimer les cookies

Page 1 sur 21, 2 SuivantLamp Ubuntu

Le choix d'Ubuntu pour mes premiers pas Linux

Mer 25 Nov, 2009 13:40

Bonjours,
Je veux créer mon site en php sous linux donc j'ai installer Lamp.
Problème, je ne sais pas dans quel dossier je doit monter mon site. Avez vous une idée ?

Merci
Draknova

Messages : 158

Mer 25 Nov, 2009 14:25

/var/www il me semble
Une ch'tio peu d'pub :http://www.ina-ich.net/

"L'ignorance n'est pas ne pas connaître, c'est ne pas vouloir connaître."
Ubuntu 11.10 | LibreOffice | GnuPlot | PidGin | irssi | suite Mozilla | VLC ...
Mikelenain

Avatar de l’utilisateur
Messages : 3651
Géo : Lyon

Mer 25 Nov, 2009 14:31

Il me semblait à moi aussi sauf que j'ai modifier/supprimer le fichier index.html qui était dedans ca n'a rien changer.
Draknova

Messages : 158

Mer 25 Nov, 2009 18:14

Bonjour,

si tu as installé Lamp dans /opt, le site doit être placé dans /opt/lampp/htdocs
Jean Pierre Bardiau
Firefox Pictures
jpbardiau

Messages : 127
Géo : Lobbes, Belgique

Jeu 26 Nov, 2009 17:10

Se suis sous ubuntu et j'ai utilisé la commande :
Code: Tout sélectionner
sudo tasksel install lamp-server


C'est toujours dans /opt ?
Draknova

Messages : 158

Jeu 26 Nov, 2009 18:09

J'ai finalement résolu le problème en réinstallant tout. Par contre j'ai un autre problème, j'ai configurer de facon a développer mon site dans /home/draknova/www
J'ai un fichier index.html qui marche parfaitement.
Je développe plusieurs site en même temps donc j'ai 2 dossiers. Mais quand je veut lancer le fichier index qui est dans un de ses dossiers, j'ai l'erreur suivante :
Code: Tout sélectionner
Forbidden

You don't have permission to access /site/ on this server.
Apache/2.2.12 (Ubuntu) Server at localhost Port 80

Il faut donc que je donne les droit d'acces à qui ? à moi ou à quelqu'un d'autre (je suis le seul utilisateur et administrateur) ?
Draknova

Messages : 158

Jeu 26 Nov, 2009 18:48

Il te faut configurer apache pour autoriser l'accès à chacun de tes répertoires/sites. Ça se passe dans le fichier apache2.conf.
Vas voir sur la doc Ubuntu-fr.
Quand tout le reste a échoué, lisez le mode d'emploi.
yostral

Avatar de l’utilisateur
Messages : 5404
Géo : Là-haut dans la montagne...

Jeu 26 Nov, 2009 19:38

Merci pour la réponse mais j'ai déjà visiter cette page. Elle ne m'aide pas vraiment car je ne comprend pas tout et surtout je ne trouve pas ce que je cherche.
Draknova

Messages : 158

Jeu 26 Nov, 2009 21:47

Je pense que tu as mal compris ou pas pris le temps de tout bien lire. Car la réponse à ce que tu cherches y est, je fais la même chose : j'ai mis un dossier www/ sur un autre disque, dans ce dossier j'ai plusieurs répertoire correspondants chacun à des sites différents.

Pour donner les droits d'accès à apache à ton répertoire ton_site, regarde du côté des Alias dans le fichier apache2.conf :

Code: Tout sélectionner
Alias /ton_site "/home/draknova/www/ton_site"
    <Directory "/home/draknova/www/ton_site">
        Options None
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>


Et tu y accède avec :
Code: Tout sélectionner
http://localhost/ton_site


Si ce n'est pas ça que tu veux, alors c'est moi qui ai mal compris :).
Quand tout le reste a échoué, lisez le mode d'emploi.
yostral

Avatar de l’utilisateur
Messages : 5404
Géo : Là-haut dans la montagne...

Ven 27 Nov, 2009 08:25

Parfait comme réponse :D
J'ai checher alias dans la page apache 2 j'ai jamais trouver ton résultat, meme pas quelque chose qui s'en approchait.
J'ai bien coller ce fragment dans apache2.conf et redemmarer apache2.
Je tente d'ouvrir http://localhost/mon_site/
Ca ne marche pas :cry:
J'ai toujours le meme problème.
Draknova

Messages : 158

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit