Nous sommes le Lun 09 Déc, 2019 03:59
Supprimer les cookies

[RESOLU]Crash de Ubuntu avec compiz fusion

Le choix d'Ubuntu pour mes premiers pas Linux

Ven 31 Oct, 2008 21:13

Bonjour à Tous !

Je rencontre un problème quand je souhaite utiliser les effets 3D de bureau et openGL en général.

Je les actives, ils fonctionnent de manière très fluide pendant quelques minutes puis le bureau crash : la souris se bloque puis se débloque, des carrés noirs apparaissent ici et là ... bref l'affichage est entièrement boulversé et le curseur se débloque par intermittence.
J'ai pensé d'abord à un problème de driver nvidia (geforce 8400M G). J'ai donc installer successivement le 177, 173 et 169 ... rien n'a arrangé les choses. J'ai tenté plusieurs version de Ubuntu ( 7.04, 7.10, 8.04 et je suis resté sur la 8.10 ) mais le problème persiste.

Étant nouveau sur Linux, j'ai fouillé de forum en forum pour tenter de trouver quelque chose. Mais je n'ai rien trouvé de probant. Je pense maintenant que le problème vient de Compiz fusion. Que puis-je faire ?
Le "direct rendering" est pourtant actif.
merci ..
Dernière édition par k-lu le Dim 02 Nov, 2008 12:32, édité 1 fois au total.
k-lu

Messages : 3

Ven 31 Oct, 2008 21:48

Bonjour k-lu et bienvenu sur Framagora.

À la description de ton problème, je pencherais pour un problème de drivers. Genre un mauvaise prise ne charge du modèle de ta carte par exemple. Mais là, seul nvidia peut faire quelque-chose.
J'ai une nvidia 7900 et je n'ai jamais eu ce genre de problème.

Essaye de démarrer sans compiz et le lancer dans un terminal, voir s'il met des messages d'erreur lors de tes bizarreries.
Quand tout le reste a échoué, lisez le mode d'emploi.
yostral

Avatar de l’utilisateur
Messages : 5404
Géo : Là-haut dans la montagne...

Ven 31 Oct, 2008 22:13

En fait la difficulté c'est de pouvoir retourner voir la console quand le bureau commence à "buguer" ... tant la navigation devient difficile ...

et puis il me semble qu'il ne s'affiche rien de neuf même quand les bugs commencent ... :
Detected PCI ID for VGA:
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
NVIDIA: Direct rendering failed; attempting indirect rendering.
Comparing resolution (1280x800) to maximum 3D texture size (8192): Passed.
Checking for Software Rasterizer: Not present.
Checking for nVidia: present.
Checking for FBConfig: NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
NVIDIA: Direct rendering failed; attempting indirect rendering.
present.
Checking for Xgl: not present.
NVIDIA: could not open the device file /dev/nvidiactl (Permission denied).
NVIDIA: Direct rendering failed; attempting indirect rendering.
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format


Y aurait il des choses à corriger dans le processus de lancement de compiz là ?

( Merci de m'avoir répondu :) ... )
k-lu

Messages : 3

Dim 02 Nov, 2008 12:31

Pour ceux qui rencontrerais le même problème, j'ai enfin trouvé une solution !
Il s'agit d'un problème récurant sur certaine carte Nvidia ... Les pilotes propriétaires ont toujours intégré à ce jour ce problème, même si Nvidia est au courant au vu de leurs forums.

La solution temporaire de ce problème est d'ouvrir une console et de mettre :
while true; do glxinfo >/dev/null; sleep 5; done

Ce la désactive à la barbare l'économie d'énergie de la carte graphique qui provoque les crashs ...

Mais j'ai trouver une nouvelle solution plus propre sur un forum Ubuntu ... il concerne les carte 7900G S mais il semble pour l'instant très bien fonctionner avec ma carte 8400 M G ...
http://doc.ubuntu-fr.org/dell_inspiron_9400?s=nvreg

Je signale résolu mon post ...
k-lu

Messages : 3

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit