Nous sommes le Jeu 02 Juil, 2020 17:52
Supprimer les cookies

Wordpress Webapp

Support et Développement des applications web portables

Mar 18 Mai, 2010 17:49

Bonjour,

J'ai deux problèmes avec Wordpress:

1°. J'ai mis le webapp Wordpress sur un ordi de mon réseau local. Lorsque je veux accéder au site Wordpress, il se connecte sous l'adresse de type 127.0.0.1/wordpress. Il ne trouve pas le site vu que mon ordi à une IP fixe qui est du type 192.168.0.3. Si je remplace manuellement 127... par 192... ça fonctionne. Comment faire pour qu'il se connecte directement sous 192.168.0.3/wordpress?

2°. Si je lance wordpress sur l'ordi où il est installé, pas de problème le site se lance bien. Par contre si je le consulte sur un autre ordi du réseau local, il y a bien le corps des messages de publier, par contre il n'y a pas de mise en page, j'ai une vulgaire page IE sans style (CSS?) Quel est le problème? J'ai essayé sous Chrome, IE, Firefox, même résultat.

Merci.
charlesmeryon

Messages : 34

Mar 18 Mai, 2010 19:17

Bonjour,

Il ne trouve pas le site vu que mon ordi à une IP fixe qui est du type 192.168.0.3
Je ne remets pas en cause le problème. Simplement la justification que tu donnes est erronée : 127.0.0.1 c'est l'adresse de bouclage, elle est équivalente à l'hôte localhost : http://fr.wikipedia.org/wiki/Localhost

Conclusion rapide : pour ton problème n°1, le souci vient de quelque part dans la configuration de ton ordi.

Pour le 2e problème, je viens de faire un essai et j'ai aussi ce comportement.
Pour corriger rapidement le problème :
WordPressPortable étant arrêté, édites le fichier WordPressPortable\App\AppInfo\startup.ini
Dans la section [UpdateOptionsValues], remplaces 127.0.0.1 par 192.168.03 puis enregistres et quittes.
Relances WordPressPortable, ça devrait fonctionner.

Par contre ça ne fonctionnera plus si tu changes la webapp de PC.
Ce qui se passe c'est que l'ordinateur du réseau essaie de charger les CSS à partir de lui-même (127.0.0.1), comme il ne les a pas, il n'en met pas.
Vécu : "J'ai une version crackée d'OpenOffice, c'est pour ça qu'elle est en anglais"
fat115

Avatar de l’utilisateur
Messages : 930
Géo : Ardèche ... du nord

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit