Nous sommes le Sam 20 Sep, 2014 11:11
Supprimer les cookies

[réglé]TeXmaker : Problème d'encodage de caractère des .tex

Sur le logiciel libre en général ou un logiciel libre en particulier

Mer 23 Août, 2006 09:17

Bonjour,

Amoureux de LaTeX, que je n'ai pour l'instant utilisé que sous win via le fameux couple TeXnicCenter+MikTeX, je veux, puisque j'ai switché sur Xubuntu, utilisé le même type d'outil sur Linux. Mon choix s'est porté sur le package tetex (classique) et sur l'éditeur avancé TeXmaker (pourquoi? : 1) parce que Kile installe trop de dépendance KDE, si j'ai mis Xfce c'est parce que je suis limité en ressources, et 2)pour la coloration synthaxique et la correction orthographique via aspell).

Mon problème : à l'ouverture des .tex édité par TeXnicCenter sous win, j'ai des problèmes d'encodage puisque tous les accents ne sont pas transmis. j'ai vu que TeXmaker utilisait par défaut l'encodage UTF-8, qui me donnait un point d'interrogation sur un losange noir à la place des accents, j'ai mis un encodage ISO-8859-1 à la place. Le résultat n'est pas meilleur :

Code: Tout sélectionner
\subsection{Utilisation d'entrées multi-dimensionnelles}


devient :

Code: Tout sélectionner
\subsection{Utilisation d'entr�s multi-dimensionnelles}


Avez vous une solution pour exploiter mes .tex édités sous win avec TeXmaker?
Dernière édition par pieral le Ven 25 Août, 2006 16:13, édité 1 fois au total.
Xubuntu 6.06 LTS
pieral

Messages : 159
Géo : toulouse

Mer 23 Août, 2006 09:54

Hello, j'avais le même problème. Donc, je pense que ton fichier tex est sur une partition fat32 (si c'est là ou tu avais tes données sous Win) et Ubuntu ne gere pas bien les accents/UTF8/fat32 (apparemment). J'ai donc modifié le /etc/fstab de Ubuntu, en enlevant la consigne utf8 pour les partitions déclarées en vfat.

Depuis, j'édite mes fichiers indiféremment sous ubuntu ou windows.

BSJ
Brownie

Messages : 74
Géo : Paris

Mer 23 Août, 2006 10:06

Brownie a écrit:Hello, j'avais le même problème. Donc, je pense que ton fichier tex est sur une partition fat32 (si c'est là ou tu avais tes données sous Win) et Ubuntu ne gere pas bien les accents/UTF8/fat32 (apparemment). J'ai donc modifié le /etc/fstab de Ubuntu, en enlevant la consigne utf8 pour les partitions déclarées en vfat.

Depuis, j'édite mes fichiers indiféremment sous ubuntu ou windows.

BSJ


Les données proviennent du disque ntfs du boulot, transférées effetivement sur une clé usb formatée en FAT.

Peut tu me préciser la modif à faire au fstab (j'ai pas encore tripotouillé ce fichier...)

merci de ton aide,
Xubuntu 6.06 LTS
pieral

Messages : 159
Géo : toulouse

Mer 23 Août, 2006 10:24

Flûte, là tu me pose une colle !! Je sais pas ou c'est que l'on déclare le système de fichier. Apparemment c'est dans le /etc/mtab ou tu as utf8. Essaie de chercher de ce coté avecd Google !!!

voilà, et pense à poster ta solution si tu t'en sors, ça peut toujours servir.
Brownie

Messages : 74
Géo : Paris

Mer 23 Août, 2006 10:40

j'ai trouvé plusieurs choses, je les poste si jamais ça peut intéresser quelqu'un. Pour ma part, je ne pourrais pas essayer acvant ce soir :wink:

sur ce site :

4bis - Si vous avez des partitions en fat32 montées dans l'arborescence, vérifiez bien dans votre fstab que vous ne continuez pas à les déclarer avec un encodage UTF-8.

Par exemple, si en éditant votre fichier /etc/fstab en superutilisateur :

Code:

sudo gedit /etc/fstab

ou
Code:

sudo nano /etc/fstab

Vérifiez bien de ne pas avoir une option iocharset=utf8, comme sur cet exemple :

/dev/hda1 /mnt/stockage2 vfat rw,user,auto,gid=100,uid=1000,umask=002,iocharset=utf8,codepage=850 0 0

Si vous n'avez pas de "iocharset=utf8" dans votre fstab, c'est parfait, n'y touchez pas.
Si vous avez une ligne contenant "iocharset=utf8" comme dans l'exemple ci-dessus enlevez-le (le "iocharset=utf8", pas la ligne !), puis enregistrez votre fichier /etc/fstab après modification.

5 - Rebootez.

6 - Enjoy.


Sur la doc d'ubuntu-fr :
Pour pouvoir employer des caractères accentués dans les noms de fichiers, il est nécessaire d"utiliser le jeu de caractère iso-8859-1 (ou iso-8859-15 pour avoir le signe €) à la place de l"UTF-8. Pour cela, il faut spécifier l"option iocharset=iso8859-1 ou iocharset=iso8859-15


et enfin sur ce fil du forum framasoft, deux solutions, une qui utilise le fstab et l'autre qui utilise un package LaTeX et qui permet de contourner le fstab.

Reste également la solution de modifier l'encodage en ligne de commande...

Je vais voir la solution qui convient à mon problème, mais apparement il s'agit quand même d'un problème récurrent malheureusement.
Xubuntu 6.06 LTS
pieral

Messages : 159
Géo : toulouse

Mer 23 Août, 2006 10:58

Pour ce qui est des options d'encodage dans fstab, il faut indiqué "nls=utf8" pour une partition NTFS, et "iocharset=utf8" pour fat32. Chez moi les lignes sont :
Code: Tout sélectionner
/dev/hda1      /media/winxp      ntfs      defaults,users,exec,nls=utf8,ro,auto,gid=1000,umask=000   0   0
/dev/hda5       /media/data     vfat    defaults,users,auto,exec,iocharset=utf8,codepage=850,umask=000,gid=1000        0       0


Pour le paquet Latex, j'utilise "latex-ucs" (dans les dépôts), et je n'ai pas de problème d'encodage...
Si ça peut t'aider.

C'est effectivement tout l'inverse de ton site... mais sans ça, j'ai des problèmes d'accent.

[Edit Léviathan]correction BBCode[/edit]
Dernière édition par yostral le Jeu 24 Août, 2006 15:56, édité 2 fois au total.
Quand tout le reste a échoué, lisez le mode d'emploi.
yostral

Avatar de l’utilisateur
Messages : 5021
Géo : Là-haut dans la montagne...

Mer 23 Août, 2006 11:08

yostral a écrit:Pour le paquet Latex, j'utilise "latex-ucs" (dans les dépôts), et je n'ai pas de problème d'encodage...
Si ça peut t'aider.


par curiosité : je suis étonné, je pensais que le problème venait de l'éditeur (en l'occurence texmaker) plutot que du source?

EDIT : pour info dans mes sources j'utilise :
Code: Tout sélectionner

\usepackage[latin1]{inputenc}

Dernière édition par pieral le Jeu 24 Août, 2006 15:48, édité 1 fois au total.
Xubuntu 6.06 LTS
pieral

Messages : 159
Géo : toulouse

Mer 23 Août, 2006 16:04

pieral a écrit:Mon problème : à l'ouverture des .tex édité par TeXnicCenter sous win, j'ai des problèmes d'encodage puisque tous les accents ne sont pas transmis. j'ai vu que TeXmaker utilisait par défaut l'encodage UTF-8, qui me donnait un point d'interrogation sur un losange noir à la place des accents, j'ai mis un encodage ISO-8859-1 à la place. Le résultat n'est pas meilleur :


Bon, comme toujours dans les problèmes de codage, il ne faut pas oublier qu'il y a plusieurs paramètres :

1. le codage du fichier lui-même (ce n'est pas parce qu'il a été fait sous win avec TeXnicCenter qu'il est forcément en iso-8859-1: ça peut être du format windows...);

2. le codage utilisé par l'éditeur en lecture et en écriture (ici, TeXmaker utilise sûrement l'encodage par défaut de la distrib, mais il est sans doute capable aussi de gérer d'autres encodages, faut chercher dans sa doc comment le lui demander);

3. le codage qu'on indique à LaTeX avec \usepackage[latin1]{inputenc} et autres.

Il y a d'autres messages sur des problèmes identiques sur le forum, là réponse à ton problème s'y trouve peut-être déjà.
Dernière édition par Sebastien le Jeu 24 Août, 2006 13:56, édité 1 fois au total.
Sebastien

Messages : 730
Géo : Sainte-Marie (974)

Ven 25 Août, 2006 09:58

Le problème de ton fichier source reviens a l'encodage des caractères accentués, certains editeurs de texte ou autre permettent de le changer.

Sinon sous latex tu peux tout a fait remplacer les é par des \'e , les è par des \`e et les ê par des \^e (idem pour les lettres autre que e), qui permet alors de ne pas poser de probleme a la lecture du .tex (et ces caractères, tu peux mêmes les tapper sur un clavier querty)


PS: TexMaker (sous win/linux/mac) est vraimon un très bon éditeur
FrancoD

Messages : 21

Ven 25 Août, 2006 16:12

Mon problème s'est résolu finalement par texMaker lui-même. En fait, Texmaker est capable de prendre en compte de nombreux codages de fichiers .tex. Par défaut, il est en UTF8. On peut changer sa configuration dans le paramétrage de l'éditeur. Seulement, il faut relancer Texmaker (sans sauver le .tex si on l'a ouvert avec) pour que les modifications soient prises en compte.

merci de l'aide en tous cas :wink:
Xubuntu 6.06 LTS
pieral

Messages : 159
Géo : toulouse

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit