Nous sommes le Dim 08 Déc, 2019 11:40
Supprimer les cookies

Page 4 sur 4Précédent 1, 2, 3, 4Ubuntu avale mon CPU, ou comment trouver le processus fautif

Le choix d'Ubuntu pour mes premiers pas Linux

Sam 28 Mars, 2009 15:31

Bonjour,

Pour commencer, as-tu essayé les options de démarrage conseillées par Téthis et celles que je t'ai proposées ? Souvent ça arrange les problèmes direct. Si tu ne l'as pas encore fait, ce serait bien que tu le fasses.

New Morning a écrit:
Athanor1 a écrit:Bluetooth : je vois ça dans ton log : en as-tu l'usage ? Si c'est non, tu peux désinstaller tout paquet contenant le mot Bluetooth ?


Je n'en ai pas l'usage, mais pas non plus la faculté de le désinstaller apparemment :
Ubuntu a écrit:Impossible de supprimer « bluez-gnome »


Ce n'est pas forcément tous les paquets blue-quelque chose qui sont à supprimer. Il faudrait le faire sur tous ceux susceptibles de faire tourner le daemon correspondant. Si tu ouvres Synaptic et que tu inscrives "blue" dans le champ de recherches, (avec l'option "nome et description") tu peux tenter de désinstaller tout paquet dont le nom contient bluetooth, en faisant attention de ne pas en supprimer un qui emmène avec lui la moitié du système (tant que tu n'as pas cliqué sur le bouton de confirmation de désinstallation tu ne risques rien).

Athanor1 a écrit:Ton log parle beaucoup d'irq attribuées juste après le retour de l'hibernation. Ce n'est pas que j'y comprenne bien plus que toi, mais en lisant il me vient une question : aurais-tu dans le BIOS des IRQ dont les numéros sont fixés pour les interfaces USB ?

Heu... là moi y en avoir pas comprendre :shock: . Mais le problème se produit aussi sans avoir été en hibernation, donc ce doit être secondaire.


Les IRQ n'ont rien à voir avec la question de l'hibernation. J'ai vu des IRQ's qui semblaient attribuées de manière fixe, donc si tu vas dans le BIOS, regardes si elles sont marquées comme réservées ou si elles sont attribuées de manière automatique (ce qui est mieux).

Athanor1 a écrit:Pour que l'extrait d'un log soit utile : il te faut relever ces 100 ou plus de lignes soit juste quand ça commence à ne plus aller du tout

Pour un après-boot, avec 800 lignes:

tail -n 800 /var/log/messages > messages.txt


Je comprend pas trop : ça me donne ça :

Code: Tout sélectionner
Mar 28 06:50:11 newmorning syslogd 1.5.0#2ubuntu6: restart.
Mar 28 07:03:49 newmorning -- MARK --
Mar 28 07:23:49 newmorning -- MARK --
Mar 28 07:43:49 newmorning -- MARK --
Mar 28 08:03:49 newmorning -- MARK --
Mar 28 08:23:49 newmorning -- MARK --
Mar 28 08:43:49 newmorning -- MARK --
Mar 28 09:03:49 newmorning -- MARK --
Mar 28 09:23:49 newmorning -- MARK --


Avec cette commande ? :shock:
Code: Tout sélectionner
tail -n 800 /var/log/messages > messages.txt


Il faut lancer cette commande juste après que tu aies fait un reboot, que tu auras opéré à la suite du problème CPU. Le but serait de découvrir des messages particuliers, donc quand le cpu monte trop et que la machine commence à être lente, note l'heure de l'horloge de ton ordi avant de rebooter, puis rebootes, puis lance cette commande, puis affiches le fichier messages.txt avec un éditeur de textes, puis sélectionnes tous les messages qui précèdent le redémarrage en te basant sur l'heure de reboot.

Le reboot se signale par cette phrase dans le log:
Mar 28 05:43:48 newmorning syslogd 1.5.0#2ubuntu6: restart.

Par contre messages.0 renvoie ce que j'ai copié là : http://pastebin.com/m67923449


Dans ce log je vois en rouge :
ACPI: If "acpi_osi=Linux" works better, please notify linux-acpi@vger.kernel.org


Donc quand tu auras testé les options : noapic nolapic et acpi=off (les deux premiers ensemble, le troisième seul, et aussi en plus des deux premiers) tu peux essayer l'option acpi_osi=Linux.

Si tu veux bien noter le résultat test par test, et revenir nous dire ce que ça donne ? :)
LinuxVillage - http://linuxvillage.org
Site d'entraide d'utilisateurs GNU/Linux
Mélodie

Messages : 4555
Géo : France

Dim 29 Mars, 2009 23:35

Athanor1 a écrit:Ce n'est pas forcément tous les paquets blue-quelque chose qui sont à supprimer. Il faudrait le faire sur tous ceux susceptibles de faire tourner le daemon correspondant. Si tu ouvres Synaptic et que tu inscrives "blue" dans le champ de recherches, (avec l'option "nome et description") tu peux tenter de désinstaller tout paquet dont le nom contient bluetooth, en faisant attention de ne pas en supprimer un qui emmène avec lui la moitié du système (tant que tu n'as pas cliqué sur le bouton de confirmation de désinstallation tu ne risques rien).


Bon, ça m'a fait désinstaller Nautilus, mais ça a été vite réparé. Il ne me reste plus qu'un seul paquet bluetooth qui s'appelle libblutoth3 qui est lié à Nautilus (entre autre).

Athanor1 a écrit:Les IRQ n'ont rien à voir avec la question de l'hibernation. J'ai vu des IRQ's qui semblaient attribuées de manière fixe, donc si tu vas dans le BIOS, regardes si elles sont marquées comme réservées ou si elles sont attribuées de manière automatique (ce qui est mieux).

Aucune trace d'IRQ dans le bios, réservé ou automatique : ça ne doit pas être configurable (en tout cas j'ai pas vu comment).

Athanor1 a écrit:
Code: Tout sélectionner
tail -n 800 /var/log/messages > messages.txt


Il faut lancer cette commande juste après que tu aies fait un reboot, que tu auras opéré à la suite du problème CPU. Le but serait de découvrir des messages particuliers, donc quand le cpu monte trop et que la machine commence à être lente, note l'heure de l'horloge de ton ordi avant de rebooter, puis rebootes, puis lance cette commande, puis affiches le fichier messages.txt avec un éditeur de textes, puis sélectionnes tous les messages qui précèdent le redémarrage en te basant sur l'heure de reboot.

Le reboot se signale par cette phrase dans le log:
Mar 28 05:43:48 newmorning syslogd 1.5.0#2ubuntu6: restart.

Tout est là je crois : http://pastebin.com/m46d93eab


Athanor1 a écrit:Donc quand tu auras testé les options : noapic nolapic et acpi=off (les deux premiers ensemble, le troisième seul, et aussi en plus des deux premiers) tu peux essayer l'option acpi_osi=Linux.

Si tu veux bien noter le résultat test par test, et revenir nous dire ce que ça donne ? :)

noapic nolapic: l'écran affiche le chargement ubuntu, puis blanchit progressivement jusqu'à être saturé. Rien ne se passe plus, plantage et reboot.
acpi=off
: ecran noir, plantage et reboot
acpi-osi=linux : idem

Pour l'instant je suis sous noapic tout seul, mais ça ne résoud pas le problème.

Autre observation : j'ai cru pouvoir m'affranchir du problème avec seamonkey à la place de firefox, mais il vient un moment où le même phénomène se produit : montée en charge du CPU, très visible avec le graphique de la commande "tload".
New Morning

Messages : 53

Lun 30 Mars, 2009 00:03

Salut,

Tu n'as pas noté l'heure du reboot comme je t'avais demandé de le faire, ou bien tu ne nous l'as pas donnée ?

Il y a ceci à la fin de ton log:

Mar 30 00:09:33 newmorning kernel: [ 25.252689] apm: BIOS not found

Est-ce que "apm" (advanced power management, peut-être ?) serait désactivé dans le BIOS ?

et ceci:
Mar 30 00:09:34 newmorning kernel: [ 25.455998] ppdev: user-space parallel port driver

utilises-tu le port parallèle de ta machine ? Si c'est non, tu peux le désactiver.

Tu devrais peut-être nous dire ce que tu as comme machine ? (Un portable ? 32 ou 64bits ?)

Regardes aussi dans le retour d'une commande "sudo lshw" dans les premiers blocs de texte pour trouver la date et révision du BIOS de cette machine.
LinuxVillage - http://linuxvillage.org
Site d'entraide d'utilisateurs GNU/Linux
Mélodie

Messages : 4555
Géo : France

Mar 31 Mars, 2009 17:26

Athanor1 a écrit:Salut,

Tu n'as pas noté l'heure du reboot comme je t'avais demandé de le faire, ou bien tu ne nous l'as pas donnée ?


Je pensais que ça allait de soit : quand ça a commencé à saturer j'ai rebooté, soit 2 minutes avant le "restart"
Athanor1 a écrit:Il y a ceci à la fin de ton log:

Mar 30 00:09:33 newmorning kernel: [ 25.252689] apm: BIOS not found

Est-ce que "apm" (advanced power management, peut-être ?) serait désactivé dans le BIOS ?

Rien trouvé à ce sujet
Athanor1 a écrit:et ceci:
Mar 30 00:09:34 newmorning kernel: [ 25.455998] ppdev: user-space parallel port driver

utilises-tu le port parallèle de ta machine ? Si c'est non, tu peux le désactiver.

Pareil, rien dans le bios. Ce serait à faire depuis linux ?
Athanor1 a écrit:Tu devrais peut-être nous dire ce que tu as comme machine ? (Un portable ? 32 ou 64bits ?)

Vi vi, toutes les infos sur le premier post de la discussion.
Athanor1 a écrit:Regardes aussi dans le retour d'une commande "sudo lshw" dans les premiers blocs de texte pour trouver la date et révision du BIOS de cette machine.

J'ai tout mis là : http://pastebin.com/m1aa9a579
La version du bios est : V1.06 (11/13/2008)

Franchement, je viens de recevoir le dernier CD ubuntu 8.10 : j'ai pas plutôt intérêt à formater et recommencer sur de bonnes bases ? C'est peut-être au cours de la mise à niveau que ça a merdé... Mais peut-être pas en même temps.

Pour l'instant j'ai passé le SATA mode de AHCI à IDE dans le bios, ça change rien et je sais pas ce que c'est mais ça me donne l'impression de faire qqchose... :twisted:
New Morning

Messages : 53

Mar 31 Mars, 2009 17:42

??? :?:

Je suivait en même temps ma console avec "tload", et la surcharge de CPU a plongé sans que je change rien. J'ai fait un nouveau tail -n 800 /var/log/messages > messages.txt et le seul message récent (plutôt avant la décroissance du CPU) était celui-ci : Mar 31 18:25:05 newmorning -- MARK --

C'est quoi --MARK-- ?

A noter aussi, tous les messages du démarage:

http://pastebin.com/m348ee6fd

Qui se termine notamment par un warning : c'est quoi ceavahi- daemon, il faut le virer ? Comment ?

Code: Tout sélectionner
Mar 31 18:05:04 newmorning kernel: [   23.639814] warning: `avahi-daemon' uses 32-bit capabilities (legacy support in use)
Mar 31 18:05:06 newmorning kernel: [   25.862416] apm: BIOS not found.
Mar 31 18:05:06 newmorning kernel: [   26.088073] ppdev: user-space parallel port driver
Mar 31 18:05:08 newmorning kernel: [   27.734461] NET: Registered protocol family 10
Mar 31 18:05:08 newmorning kernel: [   27.736036] lo: Disabled Privacy Extensions
Mar 31 18:05:15 newmorning kernel: [   34.538739] [drm] Initialized drm 1.1.0 20060810
Mar 31 18:05:15 newmorning kernel: [   34.554829] pci 0000:00:02.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
Mar 31 18:05:15 newmorning kernel: [   34.556033] [drm] Initialized i915 1.6.0 20060119 on minor 0
Mar 31 18:05:15 newmorning kernel: [   34.902724] r8169: eth0: link down
Mar 31 18:05:15 newmorning kernel: [   34.903331] ADDRCONF(NETDEV_UP): eth0: link is not ready
Mar 31 18:05:15 newmorning kernel: [   34.992461] NET: Registered protocol family 17
Mar 31 18:05:29 newmorning pulseaudio[5799]: ltdl-bind-now.c: Failed to find original dlopen loader.
Mar 31 18:05:29 newmorning pulseaudio[5801]: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Opération non permise
Mar 31 18:05:29 newmorning pulseaudio[5801]: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Opération non permise
Mar 31 18:25:05 newmorning -- MARK --
New Morning

Messages : 53

Mar 31 Mars, 2009 18:14

-- MARK -- est le moyen pour syslog (l'utilitaire devant prendre en charge les messages qui apparaissent dans /var/log/messages) de dire qu'il est toujours à l'écoute, qu'il fonctionne toujours en somme.

Et lire ceci pour Avahi. Vu qu'il me semble que ce soit utile pour le partage réseau, il serait mieux de le laisser tourner en arrière plan.
Amicalement,

Laurent
obor2

Messages : 524
Géo : belgique

Mar 31 Mars, 2009 19:28

Bonjour,

J'ai aussi Avahi dans mon système : jamais réussi à m'en débarrasser. :)

Pour cela, il aurait fallu que je compile moi-même les paquets où il est mis en dépendances, et ça c'est hors de question. Je ne veux pas faire mes paquets moi-même !

Bref, n'essaie pas de t'en débarrasser, ça ne mord pas, et ça peut même être utile.

Alors si tu réinstalles, tu réinstalle une version x86_64 ? Je te demande ça parce que tu as bien une machine 64bits mais tu ne nous as pas dit quelle version de Ubuntu tourne dessus.

(De plus quand tu dis "le cpu a plongé", je ne sais pas si c'est le cpu qui s'est noyé, qui a vu sa charge diminuer, ou sa charge exploser : ce n'est pas clair)

/Edit : je viens de regarder ton log complet, et rien ne donne d'indication particulière. Si une Ubuntu x86_64 n'en vient pas à bout, essaie d'autres distributions, au moins deux ou trois : Fedora, PCLinuxOS, Mandriva. Si le comportement de toutes est identique, alors tu voudras peut-être penser à une mise à jour du BIOS (en vérifiant d'abord s'il existe une mise à jour pour lui, voir dans ton "lshw" la date de celui-ci)
LinuxVillage - http://linuxvillage.org
Site d'entraide d'utilisateurs GNU/Linux
Mélodie

Messages : 4555
Géo : France

Mar 31 Mars, 2009 19:39

c'est la surcharge qui a plongé (le % qui était presque à 100 est revenu à 10-20 %)

Ubuntu 8.10 est installé, mais par mise à niveau de la 8.04, d'où mon interrogation sur un possible soucis lié à cette installation peu orthodoxe.

Ceci dit ce soir il a l'air en forme : pas eu besoin de rebooter en 2h30 !

Le mieux est l'ennemi du bien...
New Morning

Messages : 53

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit