Nous sommes le Mer 19 Juin, 2019 14:17
Supprimer les cookies

[framaforms] : échec de confirmation de soumission

Questions, suggestions, critiques, rapport de bugs... autour des forums, du blog, de l'annuaire et du framadvd

Mar 18 Oct, 2016 08:35

Bonjour,

non ce n'est pas un sujet sado maso.

je n'arrive pas à paramétrer l'envoi de notification et faire fonctionner le lien de confirmation de soumission.

1/ Je reçois le courriel de notif avec comme infos les paramètres par défaut (donc je reçois plein de message de pyg lors de mes tests)

2/ je clique sur le lien de confirmation et je me retrouve avec plein de message d'erreur:

Code: Tout sélectionner
    Notice : unserialize(): Error at offset 2553 of 2557 bytes dans webform_confirm_email_confirmation() (ligne 159 dans /var/www/framaforms/sites/all/modules/webform_confirm_email/webform_confirm_email.module).
    Notice : Undefined index: module dans webform_confirm_email_confirmation() (ligne 168 dans /var/www/framaforms/sites/all/modules/webform_confirm_email/webform_confirm_email.module).
    Notice : Undefined index: key dans webform_confirm_email_confirmation() (ligne 169 dans /var/www/framaforms/sites/all/modules/webform_confirm_email/webform_confirm_email.module).
    Notice : Undefined index: to dans webform_confirm_email_confirmation() (ligne 170 dans /var/www/framaforms/sites/all/modules/webform_confirm_email/webform_confirm_email.module).
    Notice : Undefined index: language dans webform_confirm_email_confirmation() (ligne 171 dans /var/www/framaforms/sites/all/modules/webform_confirm_email/webform_confirm_email.module).
    Notice : Undefined index: from dans webform_confirm_email_confirmation() (ligne 173 dans /var/www/framaforms/sites/all/modules/webform_confirm_email/webform_confirm_email.module).
    Impossible d'envoyer le courriel. Contacter l'administrateur du site si le problème persiste.
    Unable to send e-mail. Please contact the site administrator if the problem persists.


Et le formulaire n'est pas confirmé.

Merci de voir si c'est moi qui ne sais pas faire ou si c'est un bug (je peux vous transmettre des infos plus précises sur le formulaire si ça peut vous aider).
v.mabillot

Avatar de l’utilisateur
Messages : 25
Géo : Lyon

Mar 18 Oct, 2016 11:00

Salut Vincent

toutes mes excuses, j'ai en effet insuffisamment documenté une partie de la démarche :

Dans le tout dernier champ de l'onglet "Confirmation request email" (modèle d'email), il vous faut ajouter le jeton affichant l'URL de confirmation : [submission:confirm_url].

Exemple :

========

Bonjour [submission:user]

Le [submission:date:long], vous avez répondu au formulaire [current-page:url]

*IMPORTANT* : pour confirmer votre participation, veuillez simplement cliquer sur le lien suivant : [submission:confirm_url]

Votre participation ne sera pas prise en compte tant que vous n'aurez pas effectué cette action.

Les valeurs soumises sont:
[submission:values]

Cordialement,

xxxxx

=============

Il va falloir que je corrige cela ! :-/

Au pire transmet moi le lien de ton formulaire via https://contact.framasoft.org/#framaforms afin que je puisse vérifier

pyg
*Nouveau venu ? Lisez les règles d'utilisation de ce forum
*Une question à poser ? Assurez vous qu'on vous répondra
*Soutenir Framasoft ? Participez à l'annuaire !
*"T'es où ?" Inscrivez vous sur la FramaMap
pyg

Avatar de l’utilisateur
Messages : 7858
Géo : Lyonnais

Mar 18 Oct, 2016 11:28

Yes, j'avais trouvé, mais ça n'explique pas les bugs de paramétrage et surtout j'ai bien le lien mais c'est lui qui génère les erreurs listées et la confirmation n'est pas plus actée.
v.mabillot

Avatar de l’utilisateur
Messages : 25
Géo : Lyon

Dim 09 Avr, 2017 16:55

Bonjour,
J'ai le même soucis, avec les mêmes erreurs au moment d'envoyer le mail après le clic sur le lien de confirmation.
S'il y a quelque chose qui m'échappe pour pouvoir valider une adresse mail, je suis preneur de l'info.
Merci !
cedd

Messages : 1

Sam 11 Nov, 2017 21:35

Bonsoir,

J'étais avec le même problème, et l'utilisation du [submission:confirm_url] m'a permis d'avancer.
Cependant quand l'utilisateur reçoit le mail, avec une url de type (*) : https : / / framaforms.org/node/37233/submission/999999
(* j'ai inséré des espaces, parce que : utilisateurs nouvellement inscrits (moins de 2 messages) et les invités ne sont pas autorisés à insérer des liens afin d'éviter le spam... )

Il se heurte à un message :

Message d'erreur : Accès refusé. Vous avez peut-être besoin de vous identifier (ci-dessous) ou de vous enregistrer pour accéder à cette page.

Je dois louper quelque chose, car je suppose que le lien de "submission" ne nécessite pas d'avoir créé un compte pour pouvoir confirmer son mail et son inscription à un événement...

Merci de vos lumières !

Chez vous, le lien de "submission" a-t-il bien le même format ?

Et il passe ? (si vous avez pensé à vous déconnecter de votre compte administrateur sondage framaform)

Merci de votre aide

Cdt
Phil35
Phil35d

Messages : 4

Lun 13 Nov, 2017 23:54

Bonsoir,

J'ai trouvé mon erreur. Dans la configuration des Courriels,
- le premier est envoyé à l'administrateur
- le deuxième est envoyé à l'utilisateur
- le troisième est envoyé à l'utilisateur, lorsqu'il a cliqué sur le lien [submission:confirm_url] contenu dans le deuxième.

Dans mes tests, j'avais des textes très similaires dans le 2ème et 3ème cas. Et J'ai mis le lien [submission:confirm_url] dans le 3ème mail, et quand je recevais le mail de validation, le lien était un [submission:url]

Comme quoi, l'erreur était encore une fois entre la chaise et le clavier...
Trop puissant cet outil !
Phil35d

Messages : 4

Lun 11 Déc, 2017 17:43

Quelqu'un-e arrive enfin à recevoir les confirmations? Dans mes tests ça ne marche pas :-(

Erreur qui s'affiche en suivant le lien de confirmation:

"Impossible d'envoyer le courriel. Contacter l'administrateur du site si le problème persiste.
Unable to send e-mail. Please contact the site administrator if the problem persists."

Et si j'essaie par la fonction "Renvoyer les courriels" de envoyer le courriel de "Confirmation de demande…", l'erreur est:

"Aucun courriel n'a pu être envoyé à cause d'une erreur serveur."

N.B. Afin d'éviter tout problème de session, j'utilise deux navigateurs différents pour, respectivement, configuration et soumission du form...
marcoep

Messages : 1

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit